aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorB Stack <bgstack15@gmail.com>2020-05-14 11:38:50 -0400
committerB Stack <bgstack15@gmail.com>2020-05-14 11:42:07 -0400
commitad1eb2590983634cb5549be1fbe1f2bae8a24d01 (patch)
treec2924c2c63bf4a3652590f60460f26c81ec78e24 /debian/rules
parentmove dh compat down to 9 (diff)
downloadchicago95-packages-ad1eb2590983634cb5549be1fbe1f2bae8a24d01.tar.gz
chicago95-packages-ad1eb2590983634cb5549be1fbe1f2bae8a24d01.tar.bz2
chicago95-packages-ad1eb2590983634cb5549be1fbe1f2bae8a24d01.zip
remove directory for each dpkg distro
The Open Build Service uses the one debian/ and .dsc contents to build for all dpkg targets.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..bc6662c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+export debuilddir="debian"
+export buildroot="${debuilddir}/${appname}"
+export _datadir="/usr/share"
+export _bindir="/usr/bin"
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ dh_auto_install
+
+ install -m0755 -d ${buildroot}${_datadir}/sounds/Chicago95
+ install -m0644 "Extras/Microsoft Windows 95 Startup Sound.ogg" ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
+
+override_dh_auto_clean:
+ rm -f ${buildroot}${_datadir}/sounds/Chicago95/startup.ogg
+ dh_auto_clean
bgstack15