aboutsummaryrefslogtreecommitdiff
path: root/port-files/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'port-files/debian/rules')
-rwxr-xr-xport-files/debian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/port-files/debian/rules b/port-files/debian/rules
new file mode 100755
index 00000000..9f19b9b5
--- /dev/null
+++ b/port-files/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --parallel
+
+override_dh_auto_configure:
+ /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/qmake \
+ PREFIX=/usr \
+ LIBPREFIX=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ L_ETCDIR=/etc \
+ QMAKE_CXXFLAGS="$(CXXFLAGS) $(CPPFLAGS)" \
+ QMAKE_LFLAGS="$(LDFLAGS) -Wl,--as-needed" \
+ CONFIG+=nostrip
+
+override_dh_auto_clean:
+ dh_auto_clean
+ -find $(CURDIR) -name *.qm -delete
+
+override_dh_install:
+ dh_install --list-missing
+ mv $(CURDIR)/port-files/debian/lumina-desktop/usr/bin/lumina-desktop \
+ $(CURDIR)/port-files/debian/lumina-desktop/usr/bin/lumina-desktop.real
+ install -m755 $(CURDIR)/port-files/debian/lumina-desktop \
+ $(CURDIR)/port-files/debian/lumina-desktop/usr/bin/lumina-desktop
bgstack15