aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristopher Roy Bratusek <nano@jpberlin.de>2015-08-13 20:01:18 +0200
committerChristopher Roy Bratusek <nano@jpberlin.de>2015-08-13 20:01:18 +0200
commitf13507ae8900a8e3e2cf4670911e1618358db832 (patch)
treea521816f70b1215d86cbe4ff7595b464a925622c /debian
parentFixed several problems with lumina-desktop.spec file. Should (diff)
downloadlumina-f13507ae8900a8e3e2cf4670911e1618358db832.tar.gz
lumina-f13507ae8900a8e3e2cf4670911e1618358db832.tar.bz2
lumina-f13507ae8900a8e3e2cf4670911e1618358db832.zip
Update Debian GNU/Linux packaging scripts
- new GIT snapshot - improved package descriptions - minor copyright file fixes - add merge-lumina-i18n script (update translations using lumina-i18n repo)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/control24
-rw-r--r--debian/copyright3
-rwxr-xr-xdebian/merge-lumina-i18n.sh27
4 files changed, 54 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index e9151650..190ad949 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+lumina-desktop (0.8.7.828-1nano) unstable; urgency=low
+
+ * New git snapshot
+ - debian/copyright: minor syntax fixes, add Upstream-Contact
+ - debian/control: improved package descriptions
+ - debian/merge-lumina-i18n.sh: script to merge latest translations from
+ https://github.com/pcbsd/lumina-i18n.git
+
+ -- Christopher Roy Bratusek <nano@jpberlin.de> Thu, 13 Aug 2015 19:18:43 +0200
+
lumina-desktop (0.8.6-1) unstable; urgency=low
* New upstream release
diff --git a/debian/control b/debian/control
index 2aaec2fe..bbf72038 100644
--- a/debian/control
+++ b/debian/control
@@ -32,6 +32,8 @@ Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends}, ${shlibs:Depends}
Description: Library for the lumina desktop environment
Utility library for the lumina desktop environment
+ .
+ This is the debianized version of libluminautils1.
Package: libluminautils-dev
Architecture: any
@@ -54,22 +56,23 @@ Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version})
Replaces: lumina-core (<< 0.8.3.372)
Description: Configuration utility for the lumina desktop environment
- lumina-config allows one to change various aspects of lumina and fluxbox, like
- the wallpaper beeing used, startup-applications, desktop-menu and more.
+ lumina-config allows to change various aspects of lumina and fluxbox, like
+ the wallpaper beeing used, theme, icons, panel (and plugins), startup and
+ default applications, desktop-menu and more.
Package: lumina-fm
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version})
Replaces: lumina-core (<< 0.8.3.372)
Description: Filemanager for the lumina desktop environment
- Simple filemanager for lumina with support for multiple view modes and
- integrated slideshow-based picture viewer.
+ Simple filemanager for lumina with support for multiple view modes, tabbed browsing,
+ including an integrated slideshow-based picture viewer.
Package: lumina-open
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version})
Replaces: lumina-core (<< 0.8.3.372)
-Description: xdg-open like utilityfor the lumina desktop environment
+Description: xdg-open like utility for the lumina desktop environment
lumina-open handles opening of files and urls according to the system wide
mime type association. It also provides an optional selector if more than one
application is assigned with the given url or file type.
@@ -79,16 +82,19 @@ Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version})
Replaces: lumina-core (<< 0.8.3.372)
Description: Screenshot utility for the lumina desktop environment
- Simple screenshot utility that allows one to snapshot the whole desktop or a
+ Simple screenshot utility that allows to snapshot the whole desktop or a
single window after a configurable delay.
+ .
+ Optionally the window border can be hidden when taking a screenshot of a
+ single window.
Package: lumina-search
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version})
Replaces: lumina-core (<< 0.8.3.372)
Description: Search utility for the lumina desktop environment
- Simple search utility that allows one to search for applications or files and
- directories in the user's HOME directory.
+ Simple search utility that allows to search for applications or files and
+ directories in the user's HOME directory and launch or open them.
Package: lumina-info
Architecture: any
@@ -96,7 +102,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends}, libluminautils1 (= ${binary:Version
Replaces: lumina-core (<< 0.8.3.372)
Description: Basic information utility for Lumina
lumina-info display various information about the Lumina installation,
- like paths or version.
+ like paths, contributors, license or version.
Package: lumina-xconfig
Architecture: any
diff --git a/debian/copyright b/debian/copyright
index a9eb2521..1eb78299 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,9 +1,10 @@
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: lumina-desktop
+Upstream-Contact: Ken Moore <moorekou@gmail.com>
Source: https://github.com/pcbsd/lumina
Files: *
-Copyright: 2012-2015, Ken Moore (moorekou@gmail.com)
+Copyright: 2012-2015 Ken Moore <moorekou@gmail.com>
License: BSD-3-Clause
Files: debian/*
diff --git a/debian/merge-lumina-i18n.sh b/debian/merge-lumina-i18n.sh
new file mode 100755
index 00000000..66194513
--- /dev/null
+++ b/debian/merge-lumina-i18n.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+CURDIR="${PWD}"
+LNGDIR="${PWD}/lumina-i18n/ts"
+
+git clone https://github.com/pcbsd/lumina-i18n.git
+
+[[ ! -d "${LNGDIR}" ]] && (echo "something went wrong!" && exit 1)
+
+LANGS=("${LNGDIR}"/*)
+LANGS=(${LANGS[@]/*\/ts\/})
+
+UTILS=( config desktop fileinfo fm info open screenshot search xconfig )
+
+echo ${LANGS[@]}
+
+for lng in ${LANGS[@]}; do
+ for utl in ${UTILS[@]}; do
+ [[ -e "${LNGDIR}"/${lng}/lumina-${utl}.ts ]] && \
+ cp "${LNGDIR}"/${lng}/lumina-${utl}.ts \
+ "${CURDIR}"/lumina-${utl}/i18n/lumina-${utl}_${lng}.ts
+ done
+done
+
+echo "updated lumina translations."
+git commit */i18n/ -m "merge latest translations from https://github.com/pcbsd/lumina-i18n.git"
+rm -rf lumina-i18n
bgstack15