aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Moore <moorekou@gmail.com>2016-02-10 14:49:44 -0500
committerKen Moore <moorekou@gmail.com>2016-02-10 14:49:44 -0500
commit2e0e673beae393f0955a76ba55d85e0e78f030f2 (patch)
treecc3776efcad6c654043488b6e65f466e7ae75254
parentTag Lumina version 0.8.8-Release (diff)
downloadlumina-2e0e673beae393f0955a76ba55d85e0e78f030f2.tar.gz
lumina-2e0e673beae393f0955a76ba55d85e0e78f030f2.tar.bz2
lumina-2e0e673beae393f0955a76ba55d85e0e78f030f2.zip
Update the port Makefile for Lumina 0.8.8-Release (FreeBSD port).
-rw-r--r--port-files/Makefile53
1 files changed, 30 insertions, 23 deletions
diff --git a/port-files/Makefile b/port-files/Makefile
index 69eea6df..9345384e 100644
--- a/port-files/Makefile
+++ b/port-files/Makefile
@@ -2,7 +2,9 @@
# $FreeBSD$
PORTNAME= lumina
-PORTVERSION= 0.8.5
+PORTVERSION= 0.8.8
+DISTVERSIONPREFIX= v
+DISTVERSIONSUFFIX= -Release
PORTEPOCH= 1
CATEGORIES= x11
@@ -12,38 +14,43 @@ COMMENT= Lumina Desktop Environment
LICENSE= BSD3CLAUSE
RUN_DEPENDS= xorg>=0:${PORTSDIR}/x11/xorg \
- fluxbox>=0:${PORTSDIR}/x11-wm/fluxbox \
- fluxbox-tenr-styles-pack>=0:${PORTSDIR}/x11-themes/fluxbox-tenr-styles-pack \
- kde4-icons-oxygen>=0:${PORTSDIR}/x11-themes/kde4-icons-oxygen \
- xscreensaver:${PORTSDIR}/x11/xscreensaver \
- xscreensaver-demo:${PORTSDIR}/x11/xscreensaver \
- xbrightness:${PORTSDIR}/x11/xbrightness \
- numlockx:${PORTSDIR}/x11/numlockx
-
-OPTIONS_DEFINE= MULTIMEDIA
+ fluxbox>=0:${PORTSDIR}/x11-wm/fluxbox \
+ fluxbox-tenr-styles-pack>=0:${PORTSDIR}/x11-themes/fluxbox-tenr-styles-pack \
+ kde4-icons-oxygen>=0:${PORTSDIR}/x11-themes/kde4-icons-oxygen \
+ xscreensaver:${PORTSDIR}/x11/xscreensaver \
+ xscreensaver-demo:${PORTSDIR}/x11/xscreensaver \
+ xbrightness:${PORTSDIR}/x11/xbrightness \
+ numlockx:${PORTSDIR}/x11/numlockx
+
+CONFLICTS= lumina-devel-0*
+
+OPTIONS_DEFINE= MULTIMEDIA PCBSD
OPTIONS_DEFAULT= MULTIMEDIA
MULTIMEDIA_DESC= Install multimedia support backend (gstreamer)
+PCBSD_DESC= Use the PC-BSD system interface settings.
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMULTIMEDIA}
-RUN_DEPENDS+= gstreamer-plugins-core>=0:${PORTSDIR}/multimedia/gstreamer-plugins-core \
- gstreamer-plugins-ogg>=0:${PORTSDIR}/audio/gstreamer-plugins-ogg \
- gstreamer-plugins-vorbis>=0:${PORTSDIR}/audio/gstreamer-plugins-vorbis
+RUN_DEPENDS+= gstreamer1-plugins-core>=0:${PORTSDIR}/multimedia/gstreamer1-plugins-core
.endif
MAKE_JOBS_UNSAFE=yes
-USE_XORG= x11 xcomposite xdamage xrender
+USE_XORG= x11 xdamage
USE_XCB= x11extras wm
USE_LDCONFIG= yes
-USE_QT5= core gui network svg quick linguist multimedia imageformats \
- buildtools x11extras
-USES= qmake
-USE_GITHUB= yes
-GH_ACCOUNT= pcbsd
-GH_TAGNAME= v0.8.5-devel-6.25.15
-
-QMAKE_ARGS= CONFIG+="configure"
+USE_QT5= core gui network svg linguist multimedia imageformats \
+ buildtools x11extras concurrent
+USES= desktop-file-utils qmake
+USE_GITHUB= yes
+GH_ACCOUNT= pcbsd
+
+#Setup the qmake configuration options
+.if {PORT_OPTIONS:MPCBSD}
+QMAKE_ARGS= CONFIG+="configure NO_I18N PCBSD"
+.else
+QMAKE_ARGS= CONFIG+="configure NO_I18N"
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.mk> \ No newline at end of file
bgstack15