summaryrefslogtreecommitdiff
path: root/firefox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'firefox.spec')
-rw-r--r--firefox.spec129
1 files changed, 111 insertions, 18 deletions
diff --git a/firefox.spec b/firefox.spec
index 04b55c8..a9eb3f6 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -6,7 +6,7 @@
# building locally and don't want to spend 24 hours waiting for results.
%global run_firefox_tests 0
%ifarch x86_64 %{ix86}
-%global run_firefox_tests 1
+%global run_firefox_tests 0
%endif
# Don't create debuginfo rpm packages. It reduces build time as
@@ -18,10 +18,15 @@
%global debug_build 0
%global system_nss 1
-%global build_with_clang 0
%global build_with_asan 0
%global test_on_wayland 1
+%if "%{toolchain}" == "clang"
+%global build_with_clang 1
+%else
+%global build_with_clang 0
+%endif
+
# There are still build problems on s390x, see
# https://koji.fedoraproject.org/koji/taskinfo?taskID=55048351
# https://bugzilla.redhat.com/show_bug.cgi?id=1897522
@@ -29,7 +34,7 @@ ExcludeArch: s390x
# Disabled due to
# https://bugzilla.redhat.com/show_bug.cgi?id=1966949
-%if 0%{?fedora} > 34
+%if 0%{?fedora} > 33
ExcludeArch: armv7hl
%endif
@@ -113,9 +118,9 @@ ExcludeArch: armv7hl
%endif
%if %{?system_nss}
-%global nspr_version 4.21
+%global nspr_version 4.26
%global nspr_build_version %{nspr_version}
-%global nss_version 3.64
+%global nss_version 3.69
%global nss_build_version %{nss_version}
%endif
@@ -151,13 +156,13 @@ ExcludeArch: armv7hl
Summary: Mozilla Firefox Web browser
Name: firefox
-Version: 89.0
+Version: 92.0.1
Release: 1%{?pre_tag}%{?dist}
URL: https://www.mozilla.org/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
%if %{with langpacks}
-Source1: firefox-langpacks-%{version}%{?pre_version}-20210601.tar.xz
+Source1: firefox-langpacks-%{version}%{?pre_version}-20210927.tar.xz
%endif
Source2: cbindgen-vendor.tar.xz
Source10: firefox-mozconfig
@@ -199,14 +204,14 @@ Patch41: build-disable-elfhack.patch
Patch44: build-arm-libopus.patch
Patch46: firefox-nss-version.patch
Patch47: fedora-shebang-build.patch
-Patch48: build-arm-wasm.patch
+#Patch48: build-arm-wasm.patch
Patch49: build-arm-libaom.patch
Patch53: firefox-gcc-build.patch
# This should be fixed in Firefox 83
Patch54: mozilla-1669639.patch
Patch55: firefox-testing.patch
Patch57: firefox-disable-ffvpx-with-vapi.patch
-Patch58: firefox-crashreporter-build.patch
+Patch61: firefox-glibc-dynstack.patch
# Test patches
# Generate without context by
@@ -232,7 +237,9 @@ Patch407: mozilla-1667096.patch
Patch408: mozilla-1663844.patch
Patch415: mozilla-1670333.patch
Patch420: mochitest-wayland-workaround.patch
-Patch422: mozilla-1705048.patch
+Patch422: mozilla-1728749.patch
+Patch423: mozilla-1708709.patch
+Patch424: mozilla-1725828.patch
# PGO/LTO patches
Patch600: pgo.patch
@@ -329,6 +336,9 @@ BuildRequires: mutter
BuildRequires: gsettings-desktop-schemas
BuildRequires: gnome-settings-daemon
BuildRequires: mesa-dri-drivers
+BuildRequires: xorg-x11-server-Xwayland
+BuildRequires: dbus-x11
+BuildRequires: gnome-keyring
%endif
%if 0%{?run_firefox_tests}
BuildRequires: procps-ng
@@ -337,9 +347,9 @@ BuildRequires: python2.7
BuildRequires: dejavu-sans-mono-fonts
BuildRequires: dejavu-sans-fonts
BuildRequires: dejavu-serif-fonts
-BuildRequires: mesa-dri-drivers
BuildRequires: dbus-x11
BuildRequires: gnome-keyring
+BuildRequires: mesa-dri-drivers
# ----------------------------------------
BuildRequires: liberation-fonts-common
BuildRequires: liberation-mono-fonts
@@ -379,6 +389,7 @@ BuildRequires: xorg-x11-fonts-ISO8859-1-100dpi
BuildRequires: xorg-x11-fonts-misc
%endif
BuildRequires: make
+BuildRequires: pciutils-libs
Obsoletes: mozilla <= 37:1.7.13
Provides: webclient
@@ -439,13 +450,13 @@ This package contains results of tests executed during build.
%patch44 -p1 -b .build-arm-libopus
#%patch46 -p1 -b .nss-version
%patch47 -p1 -b .fedora-shebang
-%patch48 -p1 -b .build-arm-wasm
+#%patch48 -p1 -b .build-arm-wasm
%patch49 -p1 -b .build-arm-libaom
%patch53 -p1 -b .firefox-gcc-build
%patch54 -p1 -b .1669639
%patch55 -p1 -b .testing
%patch57 -p1 -b .ffvpx-with-vapi
-%patch58 -p1 -b .firefox-crashreporter-build
+#%patch61 -p1 -b .glibc-dynstack
# Test patches
%patch100 -p1 -b .firefox-tests-xpcshell
@@ -469,7 +480,9 @@ This package contains results of tests executed during build.
%patch408 -p1 -b .1663844
%patch415 -p1 -b .1670333
%patch420 -p1 -b .mochitest-wayland-workaround
-%patch422 -p1 -b .1705048
+%patch422 -p1 -b .1728749
+%patch423 -p1 -b .1708709
+%patch424 -p1 -b .1725828
# PGO patches
%if %{build_with_pgo}
@@ -727,15 +740,14 @@ cp %{SOURCE45} .
%if %{build_with_pgo}
%if %{test_on_wayland}
env | grep "WAYLAND"
-MOZ_ENABLE_WAYLAND=1 ./mach build 2>&1 | cat -
+MOZ_ENABLE_WAYLAND=1 ./mach build -v 2>&1 | cat -
%else
-xvfb-run ./mach build 2>&1 | cat -
+xvfb-run ./mach build -v 2>&1 | cat -
%endif
%else
-./mach build 2>&1 | cat -
+./mach build -v 2>&1 | cat -
%endif
-
#---------------------------------------------------------------------
%install
# run Firefox test suite
@@ -917,6 +929,17 @@ rm -rf %{buildroot}%{mozappdir}/gtk2/
rm -f %{buildroot}%{mozappdirdev}/sdk/lib/libmozjs.so
rm -f %{buildroot}%{mozappdirdev}/sdk/lib/libmozalloc.so
rm -f %{buildroot}%{mozappdirdev}/sdk/lib/libxul.so
+
+# Create a symlink to replace libnssckbi.so with p11-kit-client.so
+# instead of p11-kit-trust.so, so that Firefox can see the system
+# trust store on the host through the p11-kit RPC protocol. A symlink
+# to libnss3.so is also needed, because Firefox tries to load
+# libnssckbi.so from the same directory where libnss3.so is loaded (as
+# of Firefox 89).
+%if 0%{?flatpak}
+ln -sf /usr/lib64/libnss3.so %{buildroot}%{_libdir}/libnss3.so
+ln -sf /usr/lib64/pkcs11/p11-kit-client.so %{buildroot}%{_libdir}/libnssckbi.so
+%endif
#---------------------------------------------------------------------
# Moves defaults/preferences to browser/defaults/preferences
@@ -992,6 +1015,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/application.ini
%{mozappdir}/pingsender
%exclude %{mozappdir}/removed-files
+%if 0%{?flatpak}
+%{_libdir}/libnss3.so
+%{_libdir}/libnssckbi.so
+%endif
%{_datadir}/icons/hicolor/16x16/apps/firefox.png
%{_datadir}/icons/hicolor/22x22/apps/firefox.png
%{_datadir}/icons/hicolor/24x24/apps/firefox.png
@@ -1025,6 +1052,72 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
+* Mon Sep 27 2021 Martin Stransky <stransky@redhat.com> - 92.0.1-1
+- Updated to 92.0.1
+
+* Mon Sep 13 2021 Martin Stransky <stransky@redhat.com> - 92.0-3
+- Added fix for mozbz#1725828
+
+* Thu Sep 9 2021 Martin Stransky <stransky@redhat.com> - 92.0-2
+- Disable test
+
+* Fri Sep 3 2021 Martin Stransky <stransky@redhat.com> - 92.0-1
+- Updated to 92.0
+- Added fix for mozbz#1728749
+- Added fix for mozbz#1708709
+
+* Thu Aug 26 2021 Martin Stransky <stransky@redhat.com> - 91.0.2-1
+- Updated to 91.0.2
+
+* Mon Aug 23 2021 Martin Stransky <stransky@redhat.com> - 91.0.1-2
+- Set %%build_with_clang automatically based on %%toolchain
+ by Timm Bäder <tbaeder@redhat.com>
+- Updated Fedora UA patch by Eric Engestrom
+ (https://src.fedoraproject.org/rpms/firefox/pull-request/21)
+- Added fix for mozbz#1726515
+
+* Mon Aug 23 2021 Martin Stransky <stransky@redhat.com> - 91.0.1-1
+- Updated to 91.0.1
+
+* Tue Aug 10 2021 Martin Stransky <stransky@redhat.com> - 91.0-1
+- Updated to 91.0
+
+* Wed Aug 04 2021 Martin Stransky <stransky@redhat.com> - 90.0.2-2
+- Added fix for rhbz#1988841 - Allow unsigned extensions when installed
+ under non-user-writable dirs.
+
+* Thu Jul 22 2021 Martin Stransky <stransky@redhat.com> - 90.0.2-1
+- Updated to 90.0.2
+
+* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 90.0.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
+
+* Wed Jul 21 2021 Martin Stransky <stransky@redhat.com> - 90.0.1-1
+- Updated to 90.0.1
+- Added fixes to build on rawhide
+
+* Thu Jul 15 2021 Martin Stransky <stransky@redhat.com> - 90.0-3
+- Disabled Wayland backend on KDE due to
+ https://bugzilla.mozilla.org/show_bug.cgi?id=1714132
+
+* Tue Jul 13 2021 Martin Stransky <stransky@redhat.com> - 90.0-2
+- Added xorg-x11-server-Xwayland dependency for Mutter
+
+* Mon Jul 12 2021 Martin Stransky <stransky@redhat.com> - 90.0-1
+- Updated to 90.0
+
+* Mon Jul 12 2021 Daiki Ueno <dueno@redhat.com> - 89.0.2-3
+- flatpak: Enable loading system trust store on the host (rhbz#1766340)
+
+* Wed Jun 30 2021 Martin Stransky <stransky@redhat.com> - 89.0.2-2
+- Added fix for mozbz#1715254 (rhbz#1976892).
+
+* Thu Jun 24 2021 Martin Stransky <stransky@redhat.com> - 89.0.2-1
+- Updated to latest upstream (89.0.2)
+
+* Mon Jun 14 2021 Martin Stransky <stransky@redhat.com> - 89.0-2
+- Added fix for mozbz#1646135
+
* Tue Jun 1 2021 Martin Stransky <stransky@redhat.com> - 89.0-1
- Updated to latest upstream (89.0)
bgstack15